Spotify won’t install due to dependency with libssl0.9

libssl0.9 has moved onto version libssl1 though Spotify currently has prerequisite dependency of no more than libssl0.9 and won’t install.

You can safely install the two side by side. Download the required version from squeeze repositories and install with one of the following scripts:

32 bit:

sudo wget http://ftp.de.debian.org/debian/pool/main/o/openssl/libssl0.9.8_0.9.8o-4squeeze13_i386.deb && sudo dpkg -i libssl0.9.8_0.9.8o-4squeeze13_i386.deb 

64 bit

sudo wget http://ftp.de.debian.org/debian/pool/main/o/openssl/libssl0.9.8_0.9.8o-4squeeze13_amd64.deb && sudo dpkg -i libssl0.9.8_0.9.8o-4squeeze13_amd64.deb
[/sourcecode]

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s